WeConnect360 Outage

Incident Report for Sound Credit Union Status Page

Resolved

This issue has been resolved. If you are still running into issue, please submit ticket to Help Desk.

Thank you!
Posted May 29, 2026 - 11:05 PDT

Identified

There is currently a SQL outage, our vendor is aware of the issue and is actively investigating it.
Posted May 29, 2026 - 10:23 PDT
This incident affected: COMPANY WIDE (Shared Application (Non Member Facing)).