Test completed successfully. All production services are online.
Posted Dec 07, 2025 - 09:43 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 07, 2025 - 08:30 PST
Scheduled
As part of our commitment to resiliency, and to meet testing obligations with local municipality, we will be performing a confidence test of the generator and backup power systems that power our data center.
During this time, to prevent possible loss of data, our core system, Symitar, will be briefly brought to a soft-down state. This means any third party applications that require core (digital or phone banking, Bottomline or Terafina) will be unavailable during this time, although members can still use their cards as Visa DPS will be in stand-in mode.
Posted Dec 03, 2025 - 12:31 PST
This scheduled maintenance affected: MEMBER FACING (Member Facing Applications), DIGITAL ONLINE SERVICES (Account Opening/Digital Banking, Communication), and COMPANY WIDE (Core (Symitar)).