Service Alert: Weconnect360 - Account Search Delay

Incident Report for Sound Credit Union Status Page

Resolved

This incident has been resolved.
Posted May 28, 2026 - 08:56 PDT

Update

Account search during lead and case creation is not available at this time. We are actively working with our vendor to resolve this issue. We'll provide an update by end of business today.
Posted May 19, 2026 - 10:31 PDT

Investigating

SERVICE ALERT
SYSTEM WeConnect360

Detailed Description:
When searching for accounts there is a delay with returning results. The results will return after some time but takes longer than anticipated.

Member Impact:
Minimal

Employee Impact:
Minimal

Incident Time (start of issue):
5/18

Our Next Action:
BusinessNext has been contacted and is investigating the issue.

Primary Contact:

MSG@soundcu.com
Posted May 18, 2026 - 09:43 PDT
This incident affected: COMPANY WIDE (Shared Application (Non Member Facing)).