Puyallup Branch Intermittent internet connection

Incident Report for Sound Credit Union Status Page

Resolved

This incident has been resolved. Another upgrade is scheduled early into tomorrow at 2am.
Posted Jul 29, 2026 - 10:42 PDT

Identified

Comcast is performing maintenance work in the area to enhance Comcast Business Network. This is causing the Puyallup branches network to go in and out, creating an intermittent connection.
Posted Jul 28, 2026 - 09:33 PDT
This incident affected: MEMBER FACING (Branch Services).