Comcast Business Maintenance - Key Center

Incident Report for Sound Credit Union Status Page

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 09:52 PST

Investigating

Comcast is currently performing a network maintenance in the Key Center Region. This is actively affecting our Key Center Branch.
Posted Dec 16, 2025 - 08:27 PST
This incident affected: MEMBER FACING (Branch Services).