Power outage at Graham branch

Incident Report for Sound Credit Union Status Page

Resolved

Power restored approximately 1am.
Posted Dec 18, 2025 - 09:14 PST

Investigating

Graham branch is experiencing a power outage.
Posted Dec 17, 2025 - 09:53 PST
This incident affected: MEMBER FACING (Branch Services, ATM/ITM).