Payrailz: Intermittent OTP (One Time Passcode) Issues

Incident Report for Sound Credit Union Status Page

Resolved

The issue in which some OTP requests were intermittently failing has been fully resolved. OTP functionality is now operating as expected.
Posted Mar 25, 2026 - 11:13 PDT

Update

We are continuing to investigate this issue.
Posted Mar 25, 2026 - 10:02 PDT

Investigating

We are currently investigating an issue causing intermittent failures of OTP requests initiated through Payrailz services.

Payrailz technical teams are actively working to identify the root cause and resolve the issue.
Posted Mar 25, 2026 - 10:01 PDT
This incident affected: DIGITAL ONLINE SERVICES (Account Opening/Digital Banking).