SSO not functioning for Meridianlink, Imagecenter, and Synergy

Incident Report for Sound Credit Union Status Page

Resolved

This issue has now been resolved. Synergy, Imagecenter, and MeridianLink Single Sign On is functioning as intended. If you're still experiencing issues, please close your internet browser for 30 seconds, open it, and try again.

If it still doesn't work, please open a ticket with the Service Desk. Thank you!
Posted Mar 30, 2026 - 10:02 PDT

Update

Imagecenter and Synergy logins are resolved. Please close your internet browser for 30 seconds, reopen it, and attempt sign in.

We are currently working to confirm MeridianLink Single Sign On is functional and will update when it is resolved.
Posted Mar 30, 2026 - 09:53 PDT

Investigating

The automatic sign in is failing for the following systems (MeridianLink, Imagecenter, and Synergy) if you attempt to sign into one of these systems and receive a sign in prompt, please enter your windows credentials.

We have deployed a potential fix and it is currently rolling out to our devices.
Posted Mar 30, 2026 - 09:25 PDT
This incident affected: COMPANY WIDE (Shared Application (Non Member Facing)).